Notices
 
 

  

User Tag List

Thread: ESP and Engine light comes on when car heats up so in 20 to 30 minutes

Results 1 to 5 of 5
  1. Angry ESP and Engine light comes on when car heats up so in 20 to 30 minutes 
    #1
    Join Date
    Mar 2021
    Location
    Cape Town Sourth Africa
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Hi all.


    So I have this problem with my AUDI. It drives fine when cold. As soon as it heats up my dashboard lights up.

    OBDeleven error codes says:

    Engine: Trouble codes:
    U015100 - Lost Communication With Restraints Control Module
    static
    U021200 - Lost Communication With Steering Column Control Module
    static

    ---------------------------------------------------------------
    02 Transmission Trouble codes:
    No trouble codes found

    ---------------------------------------------------------------
    03 Brakes Trouble codes:
    U112100 - Databus missing message
    static


    ---------------------------------------------------------------
    08 Air Conditioning Trouble codes:
    No trouble codes found

    ---------------------------------------------------------------
    09 Central Electrics Trouble codes:
    No trouble codes found

    ---------------------------------------------------------------
    16 Steering Column Trouble codes:
    No trouble codes found

    ---------------------------------------------------------------
    17 Dashboard Trouble codes:
    U112100 - Databus missing message
    static


    ---------------------------------------------------------------
    19 Gateway Trouble codes:
    No trouble codes found

    ---------------------------------------------------------------
    42 Driver Door Trouble codes:
    U112100 - Databus missing message
    static


    ---------------------------------------------------------------
    44 Steering Assistance Trouble codes:
    No trouble codes found

    ---------------------------------------------------------------
    52 Passenger Door Trouble codes:
    U112100 - Databus missing message
    static

    I took the car in to the dealer and paid an arm and a leg and they concluded it may be the throttle body, but they are stumped. I took it off tested it and cleaned it, although it was pretty clean already.

    So there is no errors till the car heats up and as soon as it heats up I can hear a click in the engine. And then I can only manage to go at 10 km/h in limp mode. Unplugging the battery for 20 minutes gets the car fully operational again till it heats up again.

    When ESP comes on the engine starts shaking and running roughly.

    Under the throttle body close to the DSG stronic gearbox I can hear a buzz. I unplugged the throttle body and it is not coming from it, but somewhere below which I suspect is the cause of all my woes.

    I even tested the main relay and it seems to be functioning correctly.

    So now that the official AUDI dealer cannot really find the problem and didn't help at all I am back to needing help.

    Any suggestions will be highly appreciated.


    Kind Regards,

    Marius
     
    0 0 0
     

  2. Re: ESP and Engine light comes on when car heats up so in 20 to 30 minutes 
    #2
    Join Date
    Jan 2007
    Location
    Nottingham, England
    Posts
    37,956
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    48 Post(s)
    Tagged
    1 Thread(s)
    Quoted
    1131 Post(s)
    Engine type code and year? If it is going into limp mode as it sounds like it is, I suspect there are engine codes the scanner is not picking up.

     
    0 0 0
     

  3. Re: ESP and Engine light comes on when car heats up so in 20 to 30 minutes 
    #3
    Join Date
    Mar 2021
    Location
    Cape Town Sourth Africa
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    First of all thank you Crasher for your reply

    You asked for: Engine type code and year?

    Car: Audi A3
    Year: 2013
    Body type: Hatchback
    Engine: CMBA

    I think I need to have the ECU checked out.
     
    0 0 0
     

  4. Re: ESP and Engine light comes on when car heats up so in 20 to 30 minutes 
    #4
    Join Date
    Jan 2007
    Location
    Nottingham, England
    Posts
    37,956
    Post Thanks / Like
    Blog Entries
    2
    Mentioned
    48 Post(s)
    Tagged
    1 Thread(s)
    Quoted
    1131 Post(s)
    Could you find someone with full VCDS and a HEX NET cable to do a scan?

     
    0 0 0
     

  5. Re: ESP and Engine light comes on when car heats up so in 20 to 30 minutes 
    #5
    Join Date
    Mar 2021
    Location
    Cape Town Sourth Africa
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    So I replaced the Throttle body and car drives fine, but still have the following 2 errors.

    01 Engine

    System description: 1.4l R4 TSI
    Software number: 04E906016K
    Software version: 4913
    Hardware number: 04E907309A
    Hardware version: H08
    ODX name: EV_ECM14TFS01104E906016K
    ODX version: 002004
    Long coding: 02250012232401082000

    Trouble codes:
    U015100 - Lost Communication With Restraints Control Module
    static


    ---------------------------------------------------------------

    ---------------------------------------------------------------
    03 Brakes

    System description: ESC
    Software number: 5Q0907379AC
    Software version: 0437
    Hardware number: 5Q0907379D
    Hardware version: H75
    ODX name: EV_Brake1UDSContiMK100IPB
    ODX version: 008020
    Long coding: 10F18AA22021126F0179060401C7290851044880608094F20239000805

    Trouble codes:
    U112100 - Databus missing message
    static

    So I will have to look at the brakes and restraints. Somewhere there is a sensor not working, but at least car runs fine again. The electronics are all inter connected. Dealer even quoted me for a new ECU. Sjoe glad I did not follow their advise.
     
    0 0 0
     

Similar Threads

  1. Question No elec windows, mirrors and interior light dosen't go out after x minutes. Control Unit? No Vagcom.
    By LondonThing in forum Audi A4 - B7 Forum - 2005 - 2008
    Replies: 9
    Last Post: 16-02-2017, 07:06 PM
  2. AFS light on after 23-26 minutes
    By nafets in forum Passat - B6 Forum - 2005 - 2010
    Replies: 2
    Last Post: 21-02-2013, 04:09 PM
  3. Traction control light comes on after 20 minutes of driving
    By ste.richards in forum Golf MK4 - 1999 - 2004
    Replies: 4
    Last Post: 11-11-2011, 06:24 PM
  4. What kicks in within 2 minutes of cold engine start?? - A6 2.5TDI Auto 1998
    By freddyuk in forum Audi A6 - C5 Forum - 1998 - 2004
    Replies: 31
    Last Post: 01-11-2010, 11:51 PM
  5. Please Help loss of power whne engine heats up
    By hawheed in forum Passat - B5 Forum - 1997 -2005
    Replies: 1
    Last Post: 03-05-2010, 10:19 AM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


 



  


Disclaimer: VW Audi Forum is an "independant enthusiast website", administered in line with guidelines supplied by VAG in the UK, and is in no way related to any of the Worldwide Volkswagen,Audi,Seat,Skoda,Bentley,Bugatti,Porsche or Lamborghini group of Companies. For official up to date information on any of there vehicles, please visit the official websites. Any comments made throughout this website, are the views of the respective poster, and in no way represent the views of the VW Audi Forum Administration, or the worldwide Volkswagen & Audi Group of companies.


VW Audi Forum do not vet and are not responsible for any information which is posted in this forum. All content is viewed and used by you at your own risk and we do not warrant the accuracy or reliability of any of the information.


Copyright: Certain "words", "phrases" and "Images" used on this website by the Administration are "Copyright" of Volkswagen GB, Volkswagen AG (Germany), Audi GB, Audi AG (Germany), Volkswagen Motorsport GB, Volkswagen Motorsport AG (Germany), Audi Motorsport AG (Germany), Volkswagen Racing GB, Bentley, Bugatti, Porsche and Lamborghini. No image can be replicated by anyone WITHOUT the relevant Companies written permission.


All trademarks and copyrights remain property of their respective owners.

No part of the VW Audi Forum website or forum may be reproduced without written permission from the site administration


PLEASE NOTE - PERSONAL ABUSE, ABUSE AGAINST THIS OR ANY OTHER WEBSITE OR ANY COMPANY WILL NOT BE TOLERATED. OFFENDERS WILL BE MODERATED OR EVEN BANNED.


This website and forum are best viewed at a minimum resolution of 1024 by 768.



  



- VW AUDI Forum - The #1 Volkswagen (VW) Group Forum - Volkswagen (VW) - Audi - Seat - Skoda - Bentley - Bugatti - Lamborghini - Porsche - Scania - MAN - Ducatti - VW Audi Forum -


- www.vwaudiforum.co.uk - www.vwaudiforum.co.uk -