Notices
 

  

User Tag List

Thread: Oil level sensor fault

Results 1 to 8 of 8
  1. Exclamation Oil level sensor fault 
    #1
    Join Date
    Jan 2007
    Location
    Co-Limerick,Ireland
    Posts
    35
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Hi I have a my 03 passat tdi with on oil warning message,I have checked the wiring down to the sensor and have the following readings
    Pin1 Battery voltage
    Pin2 Ground
    Pin3 10v?
    I thought all of these readings where ok so assumed the fault was with the level sensor,I replaced this component and no change?Is there any known wiring issues with this fault or is it a control issue?If anyone has a wiring diagram and the necessary information it would be gratefully appreciated.Thank You
     
    0 0 0
     

  2. Re: Oil level sensor fault 
    #2
    Join Date
    Jul 2007
    Location
    Rochdale UK
    Posts
    50
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Try disconnecting the battery for about 10 seconds from memory as I think this clears an error. I had to do this after replacing my oil level sensor and it worked for me.

    If 10 seconds doesn't work try 30 seconds, sorry I can't remember the exact time, I don;t think it is very important.

    Cheers Ben.
     
    1 0 0
     

  3. Re: Oil level sensor fault 
    #3
    Join Date
    Nov 2008
    Location
    folkestone.kent
    Posts
    895
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    make sure the bonnet catch is not broken or the wiring to it,we had a service bulletin from bosch regarding this problem and we have had 2 passats with this fault.1 a broken bonnet contact the other a broken wire near the rad fan ......
     
    1 0 0
     

  4. Re: Oil level sensor fault 
    #4
    Join Date
    Jan 2007
    Location
    Co-Limerick,Ireland
    Posts
    35
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Thanks guys i will try both of these thoughts,where does this wiring route?Is it wired direcvtly to engine management or a different system?
     
    0 0 0
     

  5. Re: Oil level sensor fault 
    #5
    Join Date
    Nov 2008
    Location
    folkestone.kent
    Posts
    895
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    wired into alarm module in dash,but break where i have said (normally)!
     
    1 0 0
     

  6. Re: Oil level sensor fault 
    #6
    Join Date
    Jan 2007
    Location
    Co-Limerick,Ireland
    Posts
    35
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Thanks very much for your help guys assed the wiring found to be ok,disconnected the battery,this has done the trick,a technical clitch somewhere or just resetting the ecu s? Any way problem sorted !Cheers
     
    0 0 0
     

  7. Re: Oil level sensor fault 
    #7
    Join Date
    Dec 2007
    Posts
    76
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)
    Here we are almost ten years on from the original post!

    I had the self same issue today, coming home from work. Oil light flashed on amber ( 02 Passat b5 1.9tdi ) and my heart sank! it stayed on all the way home... Checked oil level asap, almost at the bottom of the stick, topped up to the top of the stamped recess, turn ignition on, amber oil light still there with audible warning? Checked level again, took car for a spin, got back to base light still on amber...... Scratched head, read this thread, disconnected battery for one minute, job done I Thank you.........
     
    0 0 0
     

  8. Re: Oil level sensor fault 
    #8
    Join Date
    Dec 2013
    Location
    From - Walney Island, Cumbria, Live in: Larkhill, Wiltshire
    Posts
    488
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)
    Quote Originally Posted by BLASTER View Post
    Here we are almost ten years on from the original post!

    I had the self same issue today, coming home from work. Oil light flashed on amber ( 02 Passat b5 1.9tdi ) and my heart sank! it stayed on all the way home... Checked oil level asap, almost at the bottom of the stick, topped up to the top of the stamped recess, turn ignition on, amber oil light still there with audible warning? Checked level again, took car for a spin, got back to base light still on amber...... Scratched head, read this thread, disconnected battery for one minute, job done I Thank you.........

    The easier option next time is disconnect the bonnet switch cable from the latch and then plug it back in. Itís likely your switch isnít working and the ECU wonít reset the fault unless it sees the bonnet was opened.


    54 Passat Wagon PD175
    99í Audi S4 Avant 2.7 QTO
     
    0 0 0
     

Similar Threads

  1. oil level sensor wiring
    By darkhorse1001 in forum Audi A4 - B5 Forum - 1995 - 2002
    Replies: 5
    Last Post: 08-05-2013, 10:52 PM
  2. audi a4 oil level fault
    By nd32 in forum Audi A4 - B5 Forum - 1995 - 2002
    Replies: 6
    Last Post: 09-02-2010, 05:23 PM
  3. oil level sensor
    By seralph in forum Passat - B5 Forum - 1997 -2005
    Replies: 5
    Last Post: 21-01-2009, 04:43 PM
  4. Please Help Oil Level sensor problems
    By jonnybobscott in forum New Member Introductions - Sponsored by BVR Automotive
    Replies: 2
    Last Post: 28-09-2008, 09:15 AM
  5. Fuel level sensor fault?
    By thor_wulff in forum Audi A4 - B5 Forum - 1995 - 2002
    Replies: 4
    Last Post: 14-04-2008, 11:41 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




  


Disclaimer: VW Audi Forum is an "independant enthusiast website", administered in line with guidelines supplied by VAG in the UK, and is in no way related to any of the Worldwide Volkswagen,Audi,Seat,Skoda,Bentley,Bugatti,Porsche or Lamborghini group of Companies. For official up to date information on any of there vehicles, please visit the official websites. Any comments made throughout this website, are the views of the respective poster, and in no way represent the views of the VW Audi Forum Administration, or the worldwide Volkswagen & Audi Group of companies.


VW Audi Forum do not vet and are not responsible for any information which is posted in this forum. All content is viewed and used by you at your own risk and we do not warrant the accuracy or reliability of any of the information.


Copyright: Certain "words", "phrases" and "Images" used on this website by the Administration are "Copyright" of Volkswagen GB, Volkswagen AG (Germany), Audi GB, Audi AG (Germany), Volkswagen Motorsport GB, Volkswagen Motorsport AG (Germany), Audi Motorsport AG (Germany), Volkswagen Racing GB, Bentley, Bugatti, Porsche and Lamborghini. No image can be replicated by anyone WITHOUT the relevant Companies written permission.


All trademarks and copyrights remain property of their respective owners.

No part of the VW Audi Forum website or forum may be reproduced without written permission from the site administration


PLEASE NOTE - PERSONAL ABUSE, ABUSE AGAINST THIS OR ANY OTHER WEBSITE OR ANY COMPANY WILL NOT BE TOLERATED. OFFENDERS WILL BE MODERATED OR EVEN BANNED.


This website and forum are best viewed at a minimum resolution of 1024 by 768.



  



- VW AUDI Forum - The #1 Volkswagen (VW) Group Forum - Volkswagen (VW) - Audi - Seat - Skoda - Bentley - Bugatti - Lamborghini - Porsche - VW Audi Forum -


- www.vwaudiforum.co.uk - www.vwaudiforum.co.uk -