Hello guys

Iím after for some help with my Audi A3 2.0 TDI 170 2010
My coil light is flashing and seems to be happening more regularly now which I guess is a good thing as maybe able narrow the fault down if itís on all the time.

Iíve scanned the car and it is showing a fault code P2563
Turbocharger Boost Control Position Sensor Circuit: Implausible Signal

I know these are the possible problems
Wiring and/or Connections from/to Vane Position Sensor (G581) faulty
Engine Control Module (ECM) faulty
Vane Position Sensor (G581) faulty
Binding Issues due to Adjustment/Turbocharger
Excessive Carbon build-up
Vacuum Leak from/to Turbocharger (Wastegate) Actuator and Solenoid Valve for Boost Pressure Control (N75)

The car drives fine no loss of power no limp mode

Iíve read our posts on other forms no one seems to come up with an answer which is why I thought I would start my own post and hopefully finding a solution

Lucky enough I have a 2007 Audi A3 170 so I can swap around sensors for testing.

Iíve swapped the boost pressure converter sensor still the same I havenít tried swapping any of the N75 sensors yet.
Iíve checked all the houses and havenít seen any kinks or splits.

I have a feeling there is the sensor on the actuator can this be tested?????
Iíve seen people mentioning using VCDS and on the measuring blocks using 034.2 34.3????
My VCDS measuring blocks donít seem to bring up the decimal point I only seem to get 034.

Basically what Iím asking is has anybody had fault code P2563 and actually managed to fix it and what did they do

Thanks for your advice and help