Hi!

I am about to sell my golf TDi.
but I have some issues. For about four or five months ago the motorlamp came on. A friend of mine ran VCDS and found several fault codes. One of them is at my biggest concern which comes to issues I am not able to fix. Believe me I’ve tried a lot of things thats listed on the web.
273’ km
The fault is:

Address 01: Engine Labels: 03G-906-016-BKC.clb
Part No SW: 03G 906 016 B HW: 028 101 147 8
Component: R4 1,9L EDC 0000SG 5645
Revision: 12345678 Serial number: VWZ7Z0C8392138
Coding: 0000071
Shop #: WSC 01286 386 08256
VCID: 224BA092FD81395583-8076


1 Fault Found:
16502 - Engine Coolant Temp. Sensor (G62)
P0118 - 000 - Signal too High
Freeze Frame:
RPM: 882 /min
Torque: 64.0 Nm
Speed: 0.0 km/h
Load: 2.7 %
Voltage: 13.98 V
Bin. Bits: 11000100
Temperature: 72.9°C
Temperature: 63.0°C


Readiness: 0 0 1 1 1

I have tried to change the G62 sensor twice. I have followed the cables to check for burns or issues with them. My motor lamp comes on on startup, with fault message «Emissions workshop» Airbag lamp comes on, with message «airbag fault». ESP lamp comes on after excactly 10 min of engine running which leaves the esp not working (but it works inside the 10 min). Temperature in the dash goes up and down. The radiator fan (big) starts running with only the ignition on(cold motor). This concerns me. I believe there is several threads about this, but I am new at this forum so I dont know how to find it hope anyone Can help me PS. I have the hole list of fault codes from VCDS.