Notices
 

  

User Tag List

Thread: Wifi hotspot setup confusion

Results 1 to 9 of 9
  1. Question Wifi hotspot setup confusion 
    #1
    Join Date
    Oct 2017
    Location
    Tadley
    Posts
    48
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    18 Post(s)
    Hi guys,

    I have a long trip to do at the weekend so want to set up the wifi hotspot so kids can use their tablets etc.

    Currently when I connect to the car wifi hotspot from my tablet I get redirected to a web site then get "page could not be loaded" - I think it's because the car is using it's built-in SIM for the data connection and I haven't bought any data packs.

    What I want to do is change the car so it uses my phone for the data connection, I think I have found the correct menu but when I try and change it to my phone it's greyed out and won't let me select it. See this pic:

    20171114_085914.jpg

    Anyone got any ideas what I'm doing wrong?

    Cheers,

    Fronty
     
    0 0 0
     

  2. Re: Wifi hotspot setup confusion 
    #2
    Join Date
    Mar 2016
    Location
    Budapest, Hungary
    Posts
    121
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)
    Just a guess, but look at the very last option, the + sign next to your Galaxy A5, open that option, maybe there is the wifi from the phone to use data with.
     
    0 0 0
     

  3. Re: Wifi hotspot setup confusion 
    #3
    Join Date
    Apr 2016
    Location
    Stansted
    Posts
    1,369
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    120 Post(s)
    I could be wrong but I don't think you can do that. If the car connects to the phone for Data, I don't believe the car's wifi can route via the phone although you probably could probably use the Android equivalent of the "Personal Hotspot" for the kids?

    With regards to the issue in your picture, is there anything that needs to be enabled on the phone?

    I also seem to remember a thread about you needing the Phone Box option to use the phone as a data source but you can resolve by making a couple of small changes via ODB11. This enables the Wifi Client mode. I will see if I can find it.
    MY16 Q7 S line 3.0 TDI (272) - Daytona Grey, Dynamic pack, Technology pack, Parking pack adv, Pan sunroof, Black leather, Bose, Matrix LED, Adv key, Driver/Pass elec memory, Sound insulating windscreen, Elec adj steering column, Heated rear seats, Heated windscreen, Rear side airbags, Audi smartphone interface, Ambient lighting, Heated steering wheel, Heated folding door mirrors.

     
    0 0 0
     

  4. Re: Wifi hotspot setup confusion 
    #4
    Join Date
    Apr 2016
    Location
    Stansted
    Posts
    1,369
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    120 Post(s)
    This is the thread with the coding required: Connecting car to home WIFI
    MY16 Q7 S line 3.0 TDI (272) - Daytona Grey, Dynamic pack, Technology pack, Parking pack adv, Pan sunroof, Black leather, Bose, Matrix LED, Adv key, Driver/Pass elec memory, Sound insulating windscreen, Elec adj steering column, Heated rear seats, Heated windscreen, Rear side airbags, Audi smartphone interface, Ambient lighting, Heated steering wheel, Heated folding door mirrors.

     
    0 0 0
     

  5. Re: Wifi hotspot setup confusion 
    #5
    Join Date
    Oct 2017
    Location
    Tadley
    Posts
    48
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    18 Post(s)
    Something different happened when I jumped in earlier. I had wondered something.... my phone normally goes "boing" when the car connects, well it did/does on my Passat, but I noticed it didn't go "boing" in the Q7, but it still connected as I could make calls etc. And I had wondered why it wasn't going "boing!"

    But this time instead of starting the car I just turned the ignition on as I wanted to sit in the car to make a call, and the MMI displayed a message along the lines of "do you want to connect your phone?", so I said yes - I thought this was a bit odd as the phone normally connects automatically, but that's normally when I just jump in and go, anyway then my phone went "boing!" and a message came up saying did I want to use my phone for data, and that all data would go over my phone and not the built-in SIM, and I said "yes". Then in connection manager it now showed my phone as being used for data, and it was no longer greyed out.

    Anyway I didn't have a chance to check the hot spot, so will try that later, but then I noticed my phone was connected via rSAP (remote SIM access protocol) which my old Passat uses. I think before (when it didn't go boing) it was connecting via the hands-free/headset profile, as don't think that provides data. I also noticed that instead of having two phone signal indicators on the MMI I now only had one, I guess before it was showing me both my phone and the inbuilt SIM signal strength, but now the inbuilt SIM was disabled it was just showing my phone's strength.

    So it seems it can connect two different ways to the phone, but I'll need to figure out why/when it connects via rSAP as opposed to HFP. More playing required when the kids are in bed I think.

    BTW, Apple devices don't support rSAP, so don't think there's any chance of using an iPhone for the data connection, unless they have now updated IOS to support it, or I might be talking out my @rse (has anyone got it working on their iPhone?)!

    I think when I have figured all this out I'll try and write something up. I'd also like to have a play with connecting the car to the home wifi although not sure what that gets me, it would be nice if I could access the jukebox remotely and copy all my music onto it from my NAS, although with only 10GB to play with it's a bit stingy - why so small? I've put a 128GB SD-card in slot 1 in the glovebox and using that at the moment but it is a bit of a drag having to remove it to copy more music on when I want to. Would be nice if I could hook the car up to the wifi and copy files off my NAS. :-)
     
    0 0 0
     

  6. Re: Wifi hotspot setup confusion 
    #6
    Join Date
    Apr 2016
    Location
    Stansted
    Posts
    1,369
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    120 Post(s)
    Your correct about rsap. The way it works for iPhones is to enable the personal hotspot on the phone and then connect the car to it via Wi-fi.
    MY16 Q7 S line 3.0 TDI (272) - Daytona Grey, Dynamic pack, Technology pack, Parking pack adv, Pan sunroof, Black leather, Bose, Matrix LED, Adv key, Driver/Pass elec memory, Sound insulating windscreen, Elec adj steering column, Heated rear seats, Heated windscreen, Rear side airbags, Audi smartphone interface, Ambient lighting, Heated steering wheel, Heated folding door mirrors.

     
    0 0 0
     

  7. Re: Wifi hotspot setup confusion 
    #7
    Join Date
    Oct 2017
    Location
    Tadley
    Posts
    48
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    18 Post(s)
    Ok I got the car's hotspot working, this is not particularly intuitive!

    I have two phones, a Galaxy A5 2016 (personal) and an iPhone 6s (work). The A5 is the primary phone and the one I want to use for data because I get 17GB a month on it and use hardly any of it.

    It was definitely connecting via HFP rather than rSAP, here are some before and after pics:

    First, if I try and connect to the wifi hotspot with the iPhone, I get this error:

    20171116_094518.jpg

    I believe this is because the car is trying to use the embedded SIM by default which doesn't have a data pack.

    I checked the Bluetooth settings on my Samsung out of curiosity (I wanted to see what changes):

    Screenshot_20171116-094631.jpg

    Now for the fun part... go into connection manager:

    20171116_094216.jpg

    On the primary phone go into the options menu:

    20171116_094255.jpg

    Select "Display Bluetooth profiles":
    20171116_094425.jpg
    Notice how car phone says "Not connected". Select it and the phone will go "boing!" (well mine does due to the notification settings), then you'll get this message:

    20171116_094701.jpg

    Select "No" and you will now be using your phone for data via rSAP:

    20171116_094713.jpg
    Notice how car phone says "connected" but handfree (HFP) is now "not connected".

    Back on connection manager we can see that the data connection is now using my phone rather than the eSIM:

    20171116_095240.jpg

    Now looking at the Bluetooth settings on the Samsung it's disabled "call audio", I've not actually tried making a call yet but suspect it'll work fine (my Passat also uses rSAP and only has "Contact access" and "SIM card access" listed and works fine):

    Screenshot_20171116-094730.jpg

    Ok so now I connected the iPhone to the car's wifi hotspot and voila!

    20171116_095133.jpg

    You may think "jeez, just enable the wifi hotspot on your phone" but I didn't want to have to keep turning that on and off as it saps the battery (and is a security risk). This way the kids tablets will auto-connect to the car wifi whenever they get in and all the data will get routed via the rSAP connection to my Samsung.

    Now I haven't checked if it connects like this automatically next time I jump in, I'm hoping that the Bluetooth connection settings are "sticky" but we'll see when I jump in to pick up the kids later whether I get the tell tale "boing!" (which means it connected via rSAP rather than HFP).

    If you haven't worked it out yet, I work in IT and am a bit of a nerd so quite like playing with stuff like this! :-)
     
    0 1 0
     

  8. Re: Wifi hotspot setup confusion 
    #8
    Join Date
    Nov 2007
    Location
    New Forest
    Posts
    431
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    16 Post(s)
    Quote Originally Posted by fronty View Post
    Ok I got the car's hotspot working, this is not particularly intuitive!

    I have two phones, a Galaxy A5 2016 (personal) and an iPhone 6s (work). The A5 is the primary phone and the one I want to use for data because I get 17GB a month on it and use hardly any of it.

    It was definitely connecting via HFP rather than rSAP, here are some before and after pics:

    First, if I try and connect to the wifi hotspot with the iPhone, I get this error:

    20171116_094518.jpg

    I believe this is because the car is trying to use the embedded SIM by default which doesn't have a data pack.

    I checked the Bluetooth settings on my Samsung out of curiosity (I wanted to see what changes):

    Screenshot_20171116-094631.jpg

    Now for the fun part... go into connection manager:

    20171116_094216.jpg

    On the primary phone go into the options menu:

    20171116_094255.jpg

    Select "Display Bluetooth profiles":
    20171116_094425.jpg
    Notice how car phone says "Not connected". Select it and the phone will go "boing!" (well mine does due to the notification settings), then you'll get this message:

    20171116_094701.jpg

    Select "No" and you will now be using your phone for data via rSAP:

    20171116_094713.jpg
    Notice how car phone says "connected" but handfree (HFP) is now "not connected".

    Back on connection manager we can see that the data connection is now using my phone rather than the eSIM:

    20171116_095240.jpg

    Now looking at the Bluetooth settings on the Samsung it's disabled "call audio", I've not actually tried making a call yet but suspect it'll work fine (my Passat also uses rSAP and only has "Contact access" and "SIM card access" listed and works fine):

    Screenshot_20171116-094730.jpg

    Ok so now I connected the iPhone to the car's wifi hotspot and voila!

    20171116_095133.jpg

    You may think "jeez, just enable the wifi hotspot on your phone" but I didn't want to have to keep turning that on and off as it saps the battery (and is a security risk). This way the kids tablets will auto-connect to the car wifi whenever they get in and all the data will get routed via the rSAP connection to my Samsung.

    Now I haven't checked if it connects like this automatically next time I jump in, I'm hoping that the Bluetooth connection settings are "sticky" but we'll see when I jump in to pick up the kids later whether I get the tell tale "boing!" (which means it connected via rSAP rather than HFP).

    If you haven't worked it out yet, I work in IT and am a bit of a nerd so quite like playing with stuff like this! :-)
    If you have 17GB per month that you hardly use, why not put that SIM in the car? I have a 20GB per month SIM that I hardly use, so that is in the car; everybody logs onto the car WI-FI and my phone uses a 500MB per month, 4 SIM but also uses the car WI-FI.

    Sent from my STV100-4 using Tapatalk
    Q7 3.0 TDI Quattro (272 HP) S-Line
    (Gone) A6 C6 AVANT 2.7TDI SE MANUAL
    Hers - Mk. VII Golf '15' 2.0 TDI BlueMotion
     
    0 0 0
     

  9. Re: Wifi hotspot setup confusion 
    #9
    Join Date
    Oct 2017
    Location
    Tadley
    Posts
    48
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    18 Post(s)
    Quote Originally Posted by ragebe View Post
    If you have 17GB per month that you hardly use, why not put that SIM in the car? I have a 20GB per month SIM that I hardly use, so that is in the car; everybody logs onto the car WI-FI and my phone uses a 500MB per month, 4 SIM but also uses the car WI-FI.

    Sent from my STV100-4 using Tapatalk
    I use the phone quite a lot so can't put the SIM in the car, however I did a long trip today, about 5 hrs in total, the kids were fine on their tablets, they used up about 6GB watching YouTube! The phone initially connected via HFP, seems it doesn't remember the changes, but actually it kinda works ok as means I can control when the data gets turned on and off, so if I get any "attitude" from my daughter, off it goes! Lol

    Sent from my Nexus 10 using Tapatalk
     
    0 0 0
     

Similar Threads

  1. Enable "Data" on Embedded Sim (Wifi HotSpot etc)
    By andyhud007 in forum Q7 - 4M Forum - 2016 -
    Replies: 3
    Last Post: 20-11-2016, 09:57 AM
  2. Phone data / hotspot
    By Gyro in forum Q7 - 4M Forum - 2016 -
    Replies: 9
    Last Post: 08-09-2016, 04:51 PM
  3. WiFi hotspot and client
    By andyhud007 in forum Q7 - 4M Forum - 2016 -
    Replies: 3
    Last Post: 29-08-2016, 11:16 AM
  4. In-car Wifi
    By srbsq7 in forum Q7 - 4M Forum - 2016 -
    Replies: 5
    Last Post: 07-06-2016, 01:23 PM
  5. Discover pro hotspot
    By lozzer in forum Golf MK7 - 2013 on
    Replies: 14
    Last Post: 06-10-2014, 09:27 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




  



Disclaimer: VW Audi Forum is an "independant enthusiast website", administered in line with guidelines supplied by VAG in the UK, and is in no way related to any of the Worldwide Volkswagen,Audi,Seat,Skoda,Bentley,Bugatti,Porsche or Lamborghini group of Companies. For official up to date information on any of there vehicles, please visit the official websites. Any comments made throughout this website, are the views of the respective poster, and in no way represent the views of the VW Audi Forum Administration, or the worldwide Volkswagen & Audi Group of companies.


VW Audi Forum do not vet and are not responsible for any information which is posted in this forum. All content is viewed and used by you at your own risk and we do not warrant the accuracy or reliability of any of the information.


Copyright: Certain "words", "phrases" and "Images" used on this website by the Administration are "Copyright" of Volkswagen GB, Volkswagen AG (Germany), Audi GB, Audi AG (Germany), Volkswagen Motorsport GB, Volkswagen Motorsport AG (Germany), Audi Motorsport AG (Germany), Volkswagen Racing GB, Bentley, Bugatti, Porsche and Lamborghini. No image can be replicated by anyone WITHOUT the relevant Companies written permission.


All trademarks and copyrights remain property of their respective owners.

No part of the VW Audi Forum website or forum may be reproduced without written permission from the site administration


PLEASE NOTE - PERSONAL ABUSE, ABUSE AGAINST THIS OR ANY OTHER WEBSITE OR ANY COMPANY WILL NOT BE TOLERATED. OFFENDERS WILL BE MODERATED OR EVEN BANNED.


This website and forum are best viewed at a minimum resolution of 1024 by 768.



  



- VW AUDI Forum - The #1 Volkswagen (VW) Group Forum - Volkswagen (VW) - Audi - Seat - Skoda - Bentley - Bugatti - Lamborghini - Porsche - VW Audi Forum -


- www.vwaudiforum.co.uk - www.vwaudiforum.co.uk -