Notices
 

  

User Tag List

Thread: MMI control knob broken

Results 1 to 7 of 7
  1. MMI control knob broken 
    #1
    Join Date
    May 2016
    Location
    Swadlincote
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Well I think my MMI control knob is on its way out, only working when apply extreme force to select items. The scroll function is ok just the pressing in to select that's playing up. Anyone else come across this and how hard/easy is it to change the button?
     
    0 0 0
     

  2. Re: MMI control knob broken 
    #2
    Join Date
    Aug 2014
    Location
    UK
    Posts
    154
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)
    Stating the obvious, but have you checked there's nothing underneath the button obstructing it? E.g. dust/dirt, bits of fluff etc. The button doesn't have much travel so it wouldn't take much to block it.

    Apart from the start button, the whole MMI control panel that surrounds the gear level is one part (I've had mine out of the car before) so replacing the button means a whole new control panel, which won't be cheap. However. it isn't too hard to remove yourself - take the gear-lever surround off, remove any screws you can see and pull hard (but not too hard because the wire to the start button is very short!). If you do remove the panel, the car will throw dire warnings about a handbrake malfunction when you refit it - don't have a heart attack (like I did) - cycling the handbrake on and off a couple of times with the ignition on is enough to fix it.

    Personally I'd wait until it's unusable and then try taking the control panel apart and cleaning it - best case scenario the button under the knob is dirty and a carefully placed application of contact cleaner will fix it. If that doesn't work you'll need a replacement control panel, so you're no worse off!
     
    0 0 0
     

  3. Re: MMI control knob broken 
    #3
    Join Date
    May 2016
    Location
    Swadlincote
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    I've blown some under it and noting came out, it feels completely normal to operate but obviously isn't making contact properly.
     
    0 0 0
     

  4. Re: MMI control knob broken 
    #4
    Join Date
    Jan 2008
    Posts
    239
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    You could, as a last resort and before replacing it, squirt some contact cleaner in there?
     
    0 0 0
     

  5. Re: MMI control knob broken 
    #5
    Join Date
    May 2016
    Location
    Swadlincote
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Yeah guess I should order some, nothing to loose. Going on my cars reliability it will no doubt be broken, never owned a car with so many problems as this Audi. Let's just say it my first and last, such a same because the car is a lovely drive but reliability is just beyond a joke.
     
    0 0 0
     

  6. Re: MMI control knob broken 
    #6
    Join Date
    Jul 2016
    Location
    Chestfield kent
    Posts
    25
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Hi How old is the car my 65 plate had a similar issue, you could feel grinding when rotating. went back to dealer they cleaned & oiled it with a kit from Audi. It is something they are aware of happening, and was told if it returns they will change the unit. All ok now was done about 6 months ago. You could try WD40 to start with. Good luck.
     
    0 0 0
     

  7. Re: MMI control knob broken 
    #7
    Join Date
    May 2016
    Location
    Swadlincote
    Posts
    11
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Mine is an old car unfortunately 62 plate, the button feels absolutely fine. Moves freely and can feel a positive click when you press it. I guess it's just not registering the electronic signal when it's pressed.
     
    0 0 0
     

Similar Threads

  1. Mmi volume control knob
    By michaelk3289 in forum Audi A6 - C6 Forum - 2005 - 2010
    Replies: 1
    Last Post: 07-12-2014, 10:56 PM
  2. B8 MMI Knob from central console not clicking
    By lemnarm in forum Audi A4 - B8 Forum - 2008 - 2015
    Replies: 5
    Last Post: 24-04-2014, 11:47 AM
  3. Volume MMI knob
    By Feltwell in forum Audi A6 - C6 Forum - 2005 - 2010
    Replies: 5
    Last Post: 21-06-2013, 10:04 PM
  4. Audi MMI Central Knob removal
    By fz0rb4 in forum Audi A6 - C6 Forum - 2005 - 2010
    Replies: 0
    Last Post: 20-04-2012, 12:32 PM
  5. Heater control knob - how does it work?
    By BenR in forum Passat - B6 Forum - 2005 - 2010
    Replies: 0
    Last Post: 25-06-2007, 10:33 AM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




  



Disclaimer: VW Audi Forum is an "independant enthusiast website", and is in no way related to any of the Worldwide Volkswagen,Audi,Seat,Skoda,Bentley,Bugatti,Porsche or Lamborghini group of Companies. For official up to date information on any of there vehicles, please visit the official websites. Any comments made throughout this website, are the views of the respective poster, and in no way represent the views of the VW Audi Forum Administration, or the worldwide Volkswagen & Audi Group of companies.


VW Audi Forum do not vet and are not responsible for any information which is posted in this forum. All content is viewed and used by you at your own risk and we do not warrant the accuracy or reliability of any of the information.


Copyright: Images used on this website by the Administration are "Copyright" of Volkswagen GB, Volkswagen AG (Germany), Audi GB, Audi AG (Germany), Volkswagen Motorsport GB, Volkswagen Motorsport AG (Germany), Audi Motorsport AG (Germany), Volkswagen Racing GB, Bentley, Bugatti, Porsche and Lamborghini. No image can be replicated by anyone WITHOUT the relevent Companies written permission.


All trademarks and copyrights remain property of their respective owners.

No part of the VW Audi Forum website or forum may be reproduced without written permission from the site administration


PLEASE NOTE - PERSONAL ABUSE, ABUSE AGAINST THIS OR ANY OTHER WEBSITE OR ANY COMPANY WILL NOT BE TOLERATED. OFFENDERS WILL BE MODERATED OR EVEN BANNED.


This website and forum are best viewed at a minimum resolution of 1024 by 768.



  



- VW AUDI Forum - The #1 Volkswagen (VW) Group Forum - Volkswagen (VW) - Audi - Seat - Skoda - Bentley - Bugatti - Lamborghini - Porsche - VW Audi Forum -


- www.vwaudiforum.co.uk - www.vwaudiforum.co.uk -