Notices
 

  

User Tag List

Thread: Egr valve non start question.

Results 1 to 7 of 7
  1. Egr valve non start question. 
    #1
    Join Date
    Jan 2016
    Location
    uk
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Sorry to bother people with another egr valve/engine valve shut off question as I know so much has been written on this. My 05 altea 1.9tdi bjb engine stalled and turns over but would not restart. I find I can only get the car to run if I pull the pipe off the nipple of the egr valve. I cleaned the unit but it made no difference, I fitted a second hand unit (yea, I know) but have identical symptoms and cure. I have a p2102 fault code showing. I don't understand why pulling the pipe off makes the car work.
     
    0 0 0
     

  2. Re: Egr valve non start question. 
    #2
    Join Date
    Oct 2008
    Location
    Pembrokeshire
    Posts
    13,123
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    22 Post(s)
    can only presumee you are pulling the pipe off the anti shudder valve, as the egr won't cause a non start but the asv will. they are both in the same unit. so for some reason you have a vacuum to the asv when you shouldn't.
    Audi 80 tdi avant with 360,000 miles...
     
    0 0 0
     

  3. Re: Egr valve non start question. 
    #3
    Join Date
    May 2007
    Posts
    1,123
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    13 Post(s)
    I could be wrong but I don't think you'd get a 2102 code if the engine has a vacuum operated ASV. But it does sound like there is vacuum being applied to the EGR valve when it shouldn't be pulling the valve open. Perhaps the EGR control solenoid is leaking or perhaps it's being switched on when it shouldn't be. You'd need to check the wiring at the solenoid block to see if there is a ground on the EGR control wire. If that checks OK then it sounds like the solenoid valve is leaking and will need replaced.

    Jim.
     
    0 0 0
     

  4. Re: Egr valve non start question. 
    #4
    Join Date
    Jan 2016
    Location
    uk
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    There are no wires to my egr unit as it is a bjb code engine. I have replaced the unit and the fault is the same.
     
    0 0 0
     

  5. Re: Egr valve non start question. 
    #5
    Join Date
    Nov 2010
    Location
    Shetland & S.Tyneside
    Posts
    1,865
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    103 Post(s)
    Are you pulling the pipe off the big silver diaphragm unit on the top or the small black one on the side of the EGR housing? The small one is the anti shudder flap, spring to open vacuum to close, the big one is the EGR. Sounds more like the anti shudder is closed while trying to start the engine. No airflow across the MAF giving you the P2102 code
     
    0 0 0
     

  6. Re: Egr valve non start question. 
    #6
    Join Date
    Jan 2016
    Location
    uk
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    I mean the small black one on the anti shudder valve. The confusing thing about my problem is that the anti shudder valve is open when starting the engine with the pipe connected or not. It will only start and run with this pipe pulled off though.
     
    0 0 0
     

  7. Re: Egr valve non start question. 
    #7
    Join Date
    Jan 2016
    Location
    uk
    Posts
    6
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by zollaf View Post
    can only presumee you are pulling the pipe off the anti shudder valve, as the egr won't cause a non start but the asv will. they are both in the same unit. so for some reason you have a vacuum to the asv when you shouldn't.
    Yes , I have only just realised this. If I put the anti-shudder valve pipe back on with the engine running then the arm of the valve slowly shuts resulting in the car stopping. So there is a vacuum when not needed. Does anyone know if the signal is from the ecu. I have replaced the valve assembly but it made no difference.
     
    0 0 0
     

Similar Threads

  1. Passat EGR Valve question
    By donniep in forum Passat - B5 Forum - 1997 -2005
    Replies: 0
    Last Post: 11-02-2014, 11:27 AM
  2. Quick EGR valve question
    By mr pies in forum Passat - B5 Forum - 1997 -2005
    Replies: 2
    Last Post: 08-01-2012, 07:24 PM
  3. Quick EGR valve question
    By PeteK in forum Passat - B5 Forum - 1997 -2005
    Replies: 5
    Last Post: 21-07-2011, 01:23 PM
  4. EGR Valve question
    By skymaster in forum Audi A4 - B6 Forum - 2002 - 2005
    Replies: 12
    Last Post: 28-12-2008, 12:05 AM
  5. EGR Valve question
    By c2crr in forum Golf - Jetta - Vento - Bora - Archive Topics
    Replies: 2
    Last Post: 25-03-2007, 05:21 PM
Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




  


Disclaimer: VW Audi Forum is an "independant enthusiast website", administered in line with guidelines supplied by VAG in the UK, and is in no way related to any of the Worldwide Volkswagen,Audi,Seat,Skoda,Bentley,Bugatti,Porsche or Lamborghini group of Companies. For official up to date information on any of there vehicles, please visit the official websites. Any comments made throughout this website, are the views of the respective poster, and in no way represent the views of the VW Audi Forum Administration, or the worldwide Volkswagen & Audi Group of companies.


VW Audi Forum do not vet and are not responsible for any information which is posted in this forum. All content is viewed and used by you at your own risk and we do not warrant the accuracy or reliability of any of the information.


Copyright: Certain "words", "phrases" and "Images" used on this website by the Administration are "Copyright" of Volkswagen GB, Volkswagen AG (Germany), Audi GB, Audi AG (Germany), Volkswagen Motorsport GB, Volkswagen Motorsport AG (Germany), Audi Motorsport AG (Germany), Volkswagen Racing GB, Bentley, Bugatti, Porsche and Lamborghini. No image can be replicated by anyone WITHOUT the relevant Companies written permission.


All trademarks and copyrights remain property of their respective owners.

No part of the VW Audi Forum website or forum may be reproduced without written permission from the site administration


PLEASE NOTE - PERSONAL ABUSE, ABUSE AGAINST THIS OR ANY OTHER WEBSITE OR ANY COMPANY WILL NOT BE TOLERATED. OFFENDERS WILL BE MODERATED OR EVEN BANNED.


This website and forum are best viewed at a minimum resolution of 1024 by 768.



  



- VW AUDI Forum - The #1 Volkswagen (VW) Group Forum - Volkswagen (VW) - Audi - Seat - Skoda - Bentley - Bugatti - Lamborghini - Porsche - VW Audi Forum -


- www.vwaudiforum.co.uk - www.vwaudiforum.co.uk -