PDA

View Full Version : Please Help EPC light on!!



mbz
26-08-2009, 05:20 AM
Hello guys

i dont know actually how explain u exactly my case so please read my post and dont get bored:(

EPC light is on , engin dosent start normaly, rpm isnt nature , losee of power, some times somke's light (black), and the big problem that the throttle dosent responding some times while driving so i was closed to die!!.

Now i know that EPC is electronic perfromence control , my throttle working by wireless ..

i toke it to get checked by local garage with Bosh computer
they only told me that throttle body problem ,and easly replace it !!

my friend told me to spray it out with a speacial carbon cleaner , we did and it become's NICE!! however for only 4 or 5 days:(
then its back

Note: i had never replaced air filter and it may cuse some problems i think,
anyway the problem is done!

Also : i had changed temperature sensor orginal vw one, rpm became fine however throttle body still gives some effacts
All wire are good condition
car is about 38000 miles
AZG 2.0L , 2002

Do you advice me guys to take it for the Dailer to get checked by their owen system ?
Although i dont trust them!!

Thank you all in here .

orienteer
26-08-2009, 03:33 PM
Buy yourself a vag-com cable that you can connect to your laptop, or a friends, to read the stored computer codes.

A trial version of Ross-Tech's software can be downloaded to try with the cable.

The forum can offer a great deal of support but the codes are crucial.

Regards, Ian

P.S. I would at least have a look at the condition of the air filter as it may be very clogged up. It is important to keep up with basic service items. When were your spark plugs last replaced or examined?

mbz
26-08-2009, 04:51 PM
i appreciate your quick response mate , for vag-com cable actually i dont know where to get it ..
is it helpfull bringing you the codes another way ? or there is deffirence between the readers ?

Air filter has bad condition howevre am cleaning it (worng idea i knew) i've forget it at all friend , Sparks i've bought orginal one's vw coste's about 60 replaced at about 28000 miles, plugs i've never replaced them and i think they look's fine .

Thank you very mutch .

orienteer
04-09-2009, 11:18 PM
Search for "vag-com" to USB cables on EBay

regards, Ian