PDA

View Full Version : Audi A4 error codes help please



desperado90
04-07-2009, 09:15 PM
My Audi A4 2.0 FSI (2003) recently developed a fault causing an intermittent judder on acceleration, mainly at low speeds, and now the engine management light is coming on periodically as well. I took it to the local mechanic and he found 3 faults logged during the diagnostic;

- 17850 EGR Valve Position Sensor Signal too high
- 17559 Bank 1, Long Term Fuel Trim, Range 1 Leanness Lower Limit Exceeded
- 17912 Intake Air Sys. Bypass Leak Detected

The mechanic said he needs to replace the EGR valve but this may not solve the problem alone. He also thinks there could be a problem with the throttle body control unit. He also mentioned Audi had to recall some of their FSI vehicles (2004 onwards) because it developed similar problem which was found to be due to people running cars on RON95 as opposed to RON98 which apparently is what they recommend in the manual. My definitely say RON95 minimum on the fuel cap but is it possible this could all be because of the fuel type I am using and if so had anyone experienced this problem before and what was the solution. My mechanic also said it would cost £150 to replace EGR valve and £450 for the new throttle control box.

saabsalltheway!
05-07-2009, 09:29 AM
hi
first thing to try is removing the egr valve and cleaning it with carb cleaner
the other 2 codes suggest a air leak check all small pipes all intake pipes and all the black engine breather pipes
have you had the codes cleared then rescaned?
paul

desperado90
05-07-2009, 10:51 PM
hi
first thing to try is removing the egr valve and cleaning it with carb cleaner
the other 2 codes suggest a air leak check all small pipes all intake pipes and all the black engine breather pipes
have you had the codes cleared then rescaned?
paul

Many thanks for the reply. I took your advice and had the EGR removed and cleaned and will have wait to see it this makes any difference. There was certainly a lot of carbon build up inside. All of the pipes are also fine. First time I had the diagnostic checked by Audi specialist, only the intake leak error was logged and he had everything cleared and rescanned. The other 2 errors appeared a week later but that was scanned by my local mechanic and I donít know if he had them cleared but would presume so. I came across a list of all codes and possible causes and it suggests the EGR valve code could be related to the faulty EGR sensor but I am not exactly sure where is this sensor located or how to check it. The Audi specialist did however say there was a voltage drop at the EGR valve of 1.5V.Could this possibly indicate fault with the solenoids?