PDA

View Full Version : scirocco gt2 engine cuts outs, HELP!!!



chumpanzie
29-07-2008, 12:59 PM
HI everyone, I have recently bought a 1990 scirocco gt2 1800cc carb. the car was great for a while but has recently been a pain. The engine cuts out after a few minutes driving then i let it sit for a minute or so then it starts and runs fine, for a few more minutes then cuts out again and so on.
at first i thought it was the engine overheating so fitted new thermostat, radiator, waterpump, radiator switch but no change to the engine cutting out. so changed coil, distributor cap and rotor arm and fuel in line filter. And the car still cuts out. the engine does seem to run too fast, so i will change the waxstat ,when i pull up to a junction i can hear that the engine is running too fast and when i park and cut the engine off and remove the key the engine will keep running very roughly for up to a minute!.
why does the engine cut out? please help, i love the car and want to keep on rockin.

Alex25
02-08-2008, 11:40 AM
Hi chumpanzie, i reckon you got **** in your tank probably from a rusty filler neck. Remove the back seat and pull out the fuel sender, enlarge the pin holes and replace. also try getting **** out of tank with magnet. If not try replacing the base plate.:biglaugh:

chumpanzie
02-08-2008, 06:17 PM
cheers alex. well it appears that the problem has blown itself out. hopefully just some dirt in carb i guess. the cooling problem was sorted with the replacements mentioned earlier.
now the problem is this sticky auto choke which has the car over running most of the time, anyone have any suggestions on repair?

Crasher
02-08-2008, 06:34 PM
The Pierburg carb can cost a lot to repair. The Scirocco suffers from the clutch cable damaging the wiring to the Thermo Time Valve on the side of the carb which can cause a fast idle and also the wax stat not closing the fast idle down. Personally I would replace the carb with the Weber manual coke carb kit, I have done literally hundreds of these over the last twenty years and they are a permanent fix. The only problem with the Weber is they are much more prone to icing in the winter so careful attention to the air filter hot air feed and manifold hot water feed systems is vital unless you want it stopping on you in cold weather.

The running on you are getting is what tends to called dieseling and is the fuel igniting from the glowing carbon and spark plugs in the combustion chamber and can be very damaging to the engine. If your engine does this you must stop it by staling the engine but make sure it is safe to do so.

chumpanzie
02-08-2008, 06:58 PM
Hey cheers crasher. great advice.
any cost ideas for the Weber manual choke carb kit?

Crasher
02-08-2008, 11:25 PM
http://www.webcon.co.uk/

hardy690
05-10-2008, 11:54 PM
:zx11: hi i seem to be suffering with the same problem with my scirocco gt2. Ive changed the coil which did nothing. it drives for a bit till its warm then just cuts out but kangaroos first then it will let you rev but when you put it under load it just dies. Then it sometimes will start straight away or you have to leave it for a bit. sometime it wont wont to start at all just cant work it out. pleases can someone help... driving me insane many thanks andy......

chumpanzie
06-10-2008, 07:01 AM
Hi Andy. it sounds like we have the same problem. i still havent changed to a pierburg carb but that does seem to be the real solution. in the meantime i changed the rotor arm, dist cap and spark plug with great improvement. the dist cap was particularly worn. still not 100 percent but a vast improvement. good luck

hardy690
06-10-2008, 10:41 PM
might try and put a feed of fuel straight into the carb so i can find if the problem is at the front or back.. before i start throwing my money in a pit .. but cheers for your help.. if you find out anymore info let us know..:beerchug:

Crasher
06-10-2008, 10:58 PM
Carb icing. Has this just started happening as it got colder?

hardy690
06-10-2008, 11:01 PM
no only happens when it gets hot..

Crasher
06-10-2008, 11:05 PM
Has it been happening more since the weather turned cold? Have you checked the condition of the fuel filler neck to see if it is corroded or has it been replaced recently?

hardy690
06-10-2008, 11:14 PM
all the fuel system was replaced before i bought the car .. only had the car about a month.. i want the engine to go in my caddy but i want to make sure it runs all ok before i do so. just cant think what it can be i am thinking its the carb but what would do it.. dirt in the carb or somthing. just dont want to spunk out for a new carb if its not that.

Crasher
07-10-2008, 01:33 PM
More than likely it is dirt in the system or carb icing due to a failed air pre-heat system or a blocked manifold to head grommet.

By the way, please donít use unpleasant words like that on this forum; you will get your wrists slapped by the mods.