PDA

View Full Version : ESP warning light



HenryCrun
18-01-2007, 03:54 PM
My good friend Minnie Bannister has a W-Reg Beetle purchased last April with just 42k miles on the clock.

Since taking ownership though, the ESP warning light has been a bit flaky. It tends to come on after negotiating a left-hand negative camber bend, or even just driving over a slight bump in the road.

I took it to VW dealer in Macclesfield who filled the air with mumbo-jumbo about transverse sensors and 80 parts and 200 labour. I only want the problem fixed, not shares in VW.

The problem is going to be investigated be same garage who fixed the emission light problem. He is not convinced that the sensor needs replacing and will investigate further. I'll keep you posted.

If anyone else has had similar problems with their VW, I'd be interested to hear from you.

Emmy
06-02-2007, 03:29 PM
Hi, I am also having the same problems. My Beetle has just done over 40,000 miles and the ESP light kept comingon, now is on pretty much permenately. Also now the emissons light has come on, even though have had a new air flow meter put in. Did you every rectify this problem, and what was the cost?? THanks

T5BVG
13-02-2008, 03:47 PM
Hi

I have the ESP problem the light comes on occasionally and then the car will make a brakeing noise. what parts did you have to buy to rectify yours?

Kindest Regards
TOM SMITH



My good friend Minnie Bannister has a W-Reg Beetle purchased last April with just 42k miles on the clock.

Since taking ownership though, the ESP warning light has been a bit flaky. It tends to come on after negotiating a left-hand negative camber bend, or even just driving over a slight bump in the road.

I took it to VW dealer in Macclesfield who filled the air with mumbo-jumbo about transverse sensors and 80 parts and 200 labour. I only want the problem fixed, not shares in VW.

The problem is going to be investigated be same garage who fixed the emission light problem. He is not convinced that the sensor needs replacing and will investigate further. I'll keep you posted.

If anyone else has had similar problems with their VW, I'd be interested to hear from you.

HenryCrun
13-02-2008, 04:27 PM
Hi Tom,

We had a local garage look at this and it seemed as if the sensor itself had been loose and after a clean up and re-setting of the system during last MOT and service, the ESP is now behaving itself and working as it should.