PDA

View Full Version : MMI powers up then shuts down



Rich9999
11-07-2017, 01:02 PM
Hi all, desperately hoping someone with greater knowledge than me can help.......

Car is 2012 61 Plate A4 Teknik


Recently, the MMI dropped all sound function, all sound controls were greyed out and inoperable via the dial, phone would connect via Bluetooth but refused to play via speakers, visual nav working but no spoken directions.

Three button reset has been tried but no joy there.


Took car to local garage where we get our cars serviced, he stuck the diagnostics on it, which threw up a few error codes, as follows:-

Infotainment - Control module information, front (2 fault codes)
00384 - - Optical data bus - Open circuit - Intermittent

00822 - - Connection digital sound package to radio - no communication - Permanent


Gateway/Quick services/Transport mode (2 fault codes)
00384 - - Optical data bus - Open circuit - Intermittent
01304 - - Radio - no communication - Permanent


He says with time he is able to trace the fault, suggests it might just be a bad connection somewhere but also said that it would be worth putting it out on the forums to see if there's a suggested starting point to try and save labour on him working through it piecemeal. He's had a play around with cables to the amp to make sure they're correctly seated, as they are easily accessible, but I'm guessing that the system didn't like that because since then the MMI will power up, go through the silver and red Audi MMI holding screen, but as it goes to either the blue text nav screen or the green text phone function screen (it seems to choose which one at random) it then shuts down immediately.

Any suggestions, pointers etc. very welcome. When it comes to car electrics it's probably best to assume you're talking to a total novice so jargon free is greatly appreciated!

Thanks in advance
Rich

33576

Gunnark100
11-07-2017, 01:15 PM
Best to double check with vcds and run optical test, but looks like radio and/or amp may be dead or similar. For 100% diagnose you need buy or get from somewhere optical loop/loops and isolate amp and/or radio and check after isolating will system run or not!