PDA

View Full Version : Question Headlight Level Sensor - 2008 A4



elgaz
28-11-2016, 03:54 PM
Just a quick query. My car failed MOT there on a broken headlight level sensor (passenger side). I am in NI where we MOT the cars at MOT centres rather than authorised garages, so I wasn't able to look under the car myself when it was on the ramp being checked by the tester. Is it a difficult job to replace this part? I can handle some mechanical jobs myself but I understand the sensor is physically located next to the suspension parts, and if it means touching any of those I think I'd just leave it to the garage. Had a look online but couldn't find any guides.

Thanks.

FLAPPERJACK76
28-11-2016, 04:57 PM
Really easy. One wiring plug and a couple of nuts to undo . Should be one on the nsf and one on the nsr.

Sent from my SM-G900F using Tapatalk

elgaz
29-11-2016, 02:42 PM
ok now I'm confused. I jacked the car up earlier in work on my lunch break to have a look underneath. Sorry for the crappy photos, was very awkward as space is tight and I was trying not to get my work clothes dirty.

Now my MOT fail sheet says 'headlight level sensor disconnected from front arm'. Yet when I looked underneath, everything looks to be attached?

http://i836.photobucket.com/albums/zz290/elgaz/image2_zpsom9q38f9.jpg

http://i836.photobucket.com/albums/zz290/elgaz/image6_zpsbkczlgxy.jpg

The only thing I noticed was a slight bit of play in this rod that connects onto the suspension arm. Is it meant to be rigid, or sit a little flusher to the arm?

http://i836.photobucket.com/albums/zz290/elgaz/image1_zpsbu22px7n.jpg

FLAPPERJACK76
29-11-2016, 11:33 PM
Can't see anything wrong with it from your pictures which IMHO could be better. Think the tester is being a bit of a jobsworth to be honest. If your headlamps are correct on the beam tester at time of test then your car should pass. That's what the mot is about "at time of test " if there is something wrong with the sensor then yes it will be out but in certain circumstances. Maybe you should ring them for clarification on what they found wrong.

Sent from my SM-G900F using Tapatalk

elgaz
30-11-2016, 12:12 AM
I rung earlier there and got chatting to the tester, he's adamant it was 'hanging off' - which it clearly isn't. And I haven't touched it either or there would be marks in the dirt on it. Strange one, I'll go back in tomorrow and ask him in person.